This might happen most of the time if you are using an plugin an 'old' & outdated plugin (third party) on the website.

If an old Facebook SDK (version 1.X) is used on the website. Facebook Messenger will not work on the website since Facebook Messenger will be incompatible with the old SDK. 

Facebook Messenger require 2.X version, released on April 30, 2014.

Did this answer your question?